Dual-Port cannot be assigned in vSphere (ESXi 5.0) - IBM System X, BladeCenter, Flex System



Source

RETAIN tip: H205893

Symptom

Only the first port of a Dual-Port adapter will appear as configurable in a vSwitch from the VMware vSphere client.

Affected configurations

The system is configured with at least one of the following:

  • VMware ESXi 5.0, any update
  • VMware ESXi 5.1, any update

The system is configured with one or more of the following IBM Options:

  • Flex System EN4132 Dual-Port 10 Gigabit Ethernet Adapter, Option part number 90Y3466, replacement part number (CRU) 90Y3469
  • Flex System EN6131 40 Gb Ethernet Switch, any n/a
  • Mellanox Dual-Port 10 Gigabit Ethernet Expansion Card (CFFh) - IBM BladeCenter, Option part number 90Y3570, replacement part number (CRU) 90Y3573
  • Mellanox ConnectX-2 Dual-Port 10 Gigabit Ethernet Adapter for IBM System x, Option part number 81Y9990, replacement part number (CRU) 81Y9993
  • Mellanox ConnectX-3 10 Gigabit Ethernet Adapter for IBM System x, Option part number 00D9690, any replacement part number (CRU)

This tip is not system specific.

Note: This does not imply that the network operating system will work under all combinations of hardware and software.

Please see the compatibility page for more information:

Solution

This behavior is a permanent limitation of the Mellanox ESXi 5 driver.

Workaround

Add a pseudo device as an uplink to an existing vSwitch by following these steps:

  1. Log into the VMware ESXi machine as root.
  2. Issue the following command to check for the available vmnic interfaces:
     

    esxcli network NIC list

  3. Issue the following command to add the device as an uplink to an existing vSwitch:
     

    esxcli network vswitch standard uplink add -u [vmnic_name] -v [vSwitch_name]

Applicable countries and regions

 


Document id:  MIGR-5090615
Last modified:  2013-10-08
Copyright © 2014 IBM Corporation