ServeRAID support CD 7.x may not boot on Intel Pentium 3 processors - Servers



Source

RETAIN tip: H187621

Symptom

The IBM ServeRAID Support CD version 7.00 and higher may not properly boot on some older IBM Netfinity and IBM eServer xSeries servers running Intel Pentium III or Intel Pentium III Xeon and older processors.

Below are several symptoms the user may see while booting to the support CD on an affected system:

  • The user may see never ending "..." while the support CD tries to detect the hardware configuration.
  • The user may be prompted to select a video adapter and/or resolution.
  • Any choices made by the user will not result in the proper start up of the bootable support CD.

Affected configurations

The system may be any of the following IBM servers:

  • Netfinity 1000, type 8477, any model
  • Netfinity 3000, type 8476, any model
  • Netfinity 3500 M10, type 8655, any model
  • Netfinity 3500 M20, type 8657, any model
  • Netfinity 3500, type 8644, any model
  • Netfinity 4000R, type 8652, any model
  • Netfinity 4500R, type 8656, any model
  • Netfinity 5000, type 8659, any model
  • Netfinity 5100, type 8658, any model
  • Netfinity 5500 M10, type 8661, any model
  • Netfinity 5500 M20, type 8662, any model
  • Netfinity 5500, type 8660, any model
  • Netfinity 5600, type 8664, any model
  • Netfinity 6000R, type 8682, any model
  • Netfinity 7000 M10, type 8680, any model
  • Netfinity 7000, type 8651, any model
  • Netfinity 7100, type 8666, any model
  • Netfinity 7600, type 8665, any model
  • Netfinity 8500R, type 8681, any model
  • xSeries 135, type 8654, any model
  • xSeries 150, type 8658, any model
  • xSeries 200, type 8478, any model
  • xSeries 220, type 8645, any model
  • xSeries 230, type 8658, any model
  • xSeries 232, type 8668, any model
  • xSeries 240, type 8664, any model
  • xSeries 250, type 8665, any model
  • xSeries 300, type 8672, any model
  • xSeries 330, type 8654, any model
  • xSeries 340, type 8656, any model
  • xSeries 342, type 8669, any model
  • xSeries 350, type 8682, any model
  • xSeries 370, type 8681, any model

The system is configured with one or more of the following IBM Options:

  • ServeRAID II Ultra SCSI Controller, Option part number 76H3584, replacement part number (FRU) 76H3587
  • ServeRAID SCSI Controller, Option part number 70G8489, replacement part number (FRU) 06H9334
  • ServeRAID-3H Ultra2 SCSI Controller, Option part number 01K7207, replacement part number (FRU) 01K7396
  • ServeRAID-3HB Ultra2 SCSI Controller, Option part number 37L6086, replacement part number (FRU) 01K7396
  • ServeRAID-3L Ultra2 SCSI Controller, Option part number 01K7364, replacement part number (FRU) 01K7352
  • ServeRAID-4H Ultra160 SCSI Controller - Cache Battery replacement part number (FRU) 37L6903
  • ServeRAID-4H Ultra160 SCSI Controller - Cache Daughter Card replacement part number (FRU) 37L6902
  • ServeRAID-4H Ultra160 SCSI Controller, Option part number 37L6889, replacement part number (FRU) 37L6892
  • ServeRAID-4L Ultra160 SCSI Controller, Option part number 37L6091, replacement part number (FRU) 09N9540
  • ServeRAID-4Lx Ultra160 SCSI Controller, Option part number 06P5740, replacement part number (FRU) 06P5741
  • ServeRAID-4M Ultra160 SCSI Controller (Japan), Option part number 19K0565, replacement part number (FRU) 00N9543
  • ServeRAID-4M Ultra160 SCSI Controller, Option part number 37L6080, replacement part number (FRU) 37L7258
  • ServeRAID-4Mx Ultra160 SCSI Controller, Option part number 06P5736, replacement part number (FRU) 06P5737

The system is configured with at least one of the following:

  • ServeRAID Support CD 7.00, 7.10, 7.12, 8.00, 8.15, 8.20, 8.30

Note: This does not imply that the network operating system will work under all combinations of hardware and software.

Please see the compatibility page for more information:

http://www.ibm.com/servers/eserver/serverproven/compat/us/
Workaround

The following options are available to a server affected by this issue:

  • ServeRAID BIOS and Firmware can be updated using the diskette images available on the IBM ServeRAID Support CD 7.12 or downloadable from the web. The downloadable diskette images from the web for the affected ServeRAID controllers are newer than the images on the support CD. Detailed update instructions are in the diskette README.
  • ServeRAID Drivers can be updated directly from the IBM ServeRAID Support CD 7.12 within the operating system, the diskette images on the CD, or downloaded from the web from Servers - ServeRAID Software Matrix.
  • ServeRAID BIOS and Firmware can be updated using the UpdateXpress tools at the IBM UpdateXpress URL below:
    IBM UpdateXpress CD v4.04 - Servers
  • To configure the ServeRAID option, use the IBM ServeRAID Support CD 6.xx.

Additional information

The IBM ServeRAID Support CD version 7.xx and above use a newer Linux kernel than previous versions of this bootable CD.

Upgrading the kernel version was required to support new features added to the software and ServeRAID 6 series of controllers. Unfortunately, the newer kernel also changed some memory management behavior for Pentium III or Pentium III Xeon based systems. ROM space utilization for PCI devices and video may result in the support CD to not properly detect and configure the servers video adapter. ROM space utilization will vary from system to system due to different BIOS versions, settings, number of PCI controllers installed, and total memory capacity, etc. These differences can cause one server to be affected while a similarly configured system will work fine.

Using a slightly older version of the IBM ServeRAID Support CD, like version 6.xx, can be used to configure ServeRAID controllers on affected systems. The CD version 6.xx can also be used when the controller is running 7.12.xx or higher BIOS and firmware. Since the controllers firmware creates the data structures on the drives, using a previous version of the support CD to configure the controller will not cause compatibility issues.

The ServeRAID Manager Application version 7.xx, and above, can be installed within respective supported operating systems and be expected to function properly. Only the bootable IBM ServeRAID Support CD version 7.xx, and above, are known to occasionally exhibit this issue.

Applicable countries and regions

 


Document id:  MIGR-66102
Last modified:  2014-08-18
Copyright © 2014 IBM Corporation