UpdateXpress System Pack Installer (UXSPI) show incorrect new version after tape firmware update - IBM Systems



Source

RETAIN tip: H21420

Symptom

When using the UpdateXpress System Pack Installer (UXSPI) v. 9.40 to update the firmware for tape, UXSPI may show incorrect new package versions together with the correct one.

For example:

  (4) [*] IBM DDS tape drive firmware update
Category : Tape
Severity : Initial Release
Reboot : Not Required
Update ID : ibm_fw_tape_dds-1.1_linux_32-64
Requisites : None

Update : Tape:IBM DDS Gen5
New Version : A1BB
Installed Version : BU01

Update : Tape:IBM DDS Gen5
New Version : BU01
Installed Version : BU01

Update : Tape:IBM DDS Gen5
New Version : C0AB
Installed Version : BU01

Affected configurations

The system is configured with at least one of the following:

  • UpdateXpress System Pack Installer (UXSPI), any version

This tip is not system specific.

This tip is not option specific.

Note: This does not imply that the network operating system will work under all combinations of hardware and software.

Please see the compatibility page for more information:

Solution

This behavior will be corrected in a future release of UpdateXpress System Pack Installer (UXSPI).

The target date for this release is scheduled for third quarter 2013.

The file is or will be available by selecting the appropriate Product Group, type of System, Product name, Product machine type, and Operating system on IBM Support's Fix Central web page, at the following URL:

Workaround

UpdateXpress System Pack Installer (UXSPI) will show incorrect tape firmware versions together with the correct one. The version with the same initial letter is the correct one.

Additional information

A tape firmware update package lists out several versions for one tape ID. For instance, Tape ID: IBM DDS Gen5 has three possible new versions: A1BB, BU01, and C0AB in 'ibm_fw_tape_dds-1.1_linux_32-64'.

The package also provides regular expressions such as A???, B???, and C???, which can be used to indicate which new version should be shown. UpdateXpress System Pack Installer (UXSPI) v. 9.40 have problems in handling the regular expression, and will show all the possible new versions.

The issue will be fixed in the release of UXSPI v. 9.41, planned for third quarter 2013.

Applicable countries and regions

 


Document id:  MIGR-5093203
Last modified:  2013-08-13
Copyright © 2014 IBM Corporation